DCP-Portal 5.3.1 Calendar.php Cross-Site Scripting Vulnerability

2003-03-19T00:00:00
ID EDB-ID:22387
Type exploitdb
Reporter Ertan Kurt
Modified 2003-03-19T00:00:00

Description

DCP-Portal 5.3.1 Calendar.php Cross Site Scripting Vulnerability. CVE-2003-1536. Webapps exploit for php platform

                                        
                                            source: http://www.securityfocus.com/bid/7144/info

It has been reported that DCP-Portal does not sufficiently filter URI parameters supplied to the DCP-Portal 'calender' script. 

As a result of this deficiency, it is possible for a remote attacker to create a malicious link containing script code that will be executed in the browser of a legitimate user. All code will be executed within the context of the website running DCP-Portal. 

This may allow for theft of cookie-based authentication credentials and other attacks.

This vulnerability was reported to affect DCP-Portal version 5.3.1, it is not currently known if other versions are affected.

http://www.example.com/calendar.php?year=<script>alert(document.cookie);</script>&month=03&day=05