Mambo Site Server 4.0.10 index.php Cross-Site Scripting Vulnerability

2003-03-18T00:00:00
ID EDB-ID:22382
Type exploitdb
Reporter Ertan Kurt
Modified 2003-03-18T00:00:00

Description

Mambo Site Server 4.0.10 index.php Cross Site Scripting Vulnerability. CVE-2003-1203. Webapps exploit for php platform

                                        
                                            source: http://www.securityfocus.com/bid/7135/info

Mambo Site Server has been reported prone to a cross-site scripting vulnerability.

It has been reported that certain user supplied URI parameters are not sufficiently sanitized by the Mambo Site Server. As a result of this deficiency an attacker may create a specially crafted URL that includes malicious HTML code passed to the index page used by Mambo Site server. 

This may allow for theft of cookie-based authentication credentials and other attacks.

This vulnerability was reported to affect Mambo Site Server version 4.0.10 it is not currently known if other versions are affected.

http://www.example.com/index.php?option=search&searchword=<script>alert(document.cookie);</script>