Multitech RouteFinder 550 - Remote Memory Corruption Vulnerability

2003-03-11T00:00:00
ID EDB-ID:22345
Type exploitdb
Reporter Peter Kruse
Modified 2003-03-11T00:00:00

Description

Multitech RouteFinder 550 Remote Memory Corruption Vulnerability. CVE-2003-0125. Dos exploits for multiple platform

                                        
                                            source: http://www.securityfocus.com/bid/7067/info

A vulnerability has been discovered in Multitech RouteFinder 550 VPN firmware release 4.63 and earlier. The problem occurs due to insufficient bounds checking of data supplied in HTTP GET requests. By passing excessive data to the device it may be possible for a remote attacker to corrupt memory.

Successful exploitation of this bug may result in a denial of service, causing the device to crash. Although it has not been confirmed, it may also be possible for an attacker to exploit this issue to execute arbitrary commands.

GET /OPTIONS AAAAA..[Ax10001]..AAAAA.HTML
HTTP/1.1