IBM Websphere Edge Server 3.6/4.0 - Cross-Site Scripting Vulnerability

ID EDB-ID:21947
Type exploitdb
Reporter Rapid7
Modified 2002-10-23T00:00:00


IBM Websphere Edge Server 3.6/4.0 Cross Site Scripting Vulnerability. CVE-2002-1167. Remote exploit for unix platform


A vulnerability has been discoverered in the Caching Proxy component bundled with the IBM Websphere Edge Server.

It has been reported that the Caching Proxy is vulnerable to cross site scripting attacks. Due to insufficient sanitization of user-supplied input it is possible for an attacker to construct a malicious link which contains arbitrary HTML and script code, which will be executed in the web client of a user who visits the malicious link.

Attacks of this nature may make it possible for attackers to steal cookie-based authentication credentials.

Request the following path from the caching proxy server: