Apache Tomcat 4.1 - JSP Request Cross-Site Scripting Vulnerability

ID EDB-ID:21734
Type exploitdb
Reporter Skinnay
Modified 2002-08-21T00:00:00


Apache Tomcat 4.1 JSP Request Cross Site Scripting Vulnerability. CVE-2002-1567. Remote exploit for unix platform

                                            source: http://www.securityfocus.com/bid/5542/info

Jakarta Tomcat is a Java Servlet and JSP server produced by the Apache Software Foundation. Tomcat is available for Microsoft Windows, Linux, and other Unix based operating systems.

A cross site scripting vulnerability has been reported in some versions of Tomcat. Reportedly, if a HTTP request is made for a JSP, malicious script code embedded in the URI may be included in a page generated by Tomcat.

This may be related to the issues discussed in BID 2982. This has not, however, been confirmed.