Imatix Xitami 2.5 GSL Template Cross-Site Scripting Vulnerability

ID EDB-ID:21554
Type exploitdb
Reporter Matthew Murphy
Modified 2002-06-14T00:00:00


Imatix Xitami 2.5 GSL Template Cross Site Scripting Vulnerability. CVE-2002-1965. Remote exploit for windows platform


Imatix Xitami is a webserver for Microsoft Windows operating systems.

It is possible for attackers to construct a URL that will cause scripting code to be embedded in error pages.

Xitami fails to check URLs for the presence of script commands when generating error pages returned from sample scripts that use Errors.gsl, allowing attacker supplied code to execute. As a result, when an innocent user follows such a link, the script code will execute within the context of the hosted site.