Oracle HTTP Server - XSS Header Injection

2011-06-13T00:00:00
ID EDB-ID:17393
Type exploitdb
Reporter Yasser ABOUKIR
Modified 2011-06-13T00:00:00

Description

Oracle HTTP Server - XSS Header Injection. Webapps exploits for multiple platform

                                        
                                            ---------------------------------------------------------------------------------------------------------
          Oracle HTTP Server XSS Header Injection 
---------------------------------------------------------------------------------------------------------
# Attack Pattern ID  : CAPEC-86
# CWE ID             : CI-79
# OWASP IDs          : A1-Injections, A2-Cross Site Scripting (XSS)
# CVE ID             : not yet
# Related CVEs       : CVE-2006-3918, CVE-2007-0275
# A.K.A              : Unfiltered Header Injection
# Product Type       : Application
# Vendor             : Oracle Corporation
# Product            : Oracle HTTP Server for Oracle Application Server 10g
# Vulnerable Versions: 10.1.2.0.2  
# Probably Vulnerable: (not tested) 10.1.2.0.0, 9.0.4.3.0, 9.0.4.2.0, 9.0.4.1.0, 9.0.4.0.0
# Severity           : Medium
# Tested on	     : Linux, Windows Server 2003
# Download link      : http://www.oracle.com/technetwork/middleware/ias/downloads/101201se-090616.html
# Date               : 12/06/2011
# Google Dork        : allintitle:"Oracle HTTP Server -"
-------------------------------------------------------------------------------------------------------
[-] Credit    : Yasser ABOUKIR
[-] Site      : http://www.yaboukir.com 
[-] Email     : yaboukir@gmail.com
[-] Occupation: ITC security engineering student at ENSIAS - Morocco
-------------------------------------------------------------------------------------------------------
[+] Vulnerability description:
	The Oracle HTTP Server does not sanitize the Expect header from an HTTP request when it is reflected back in an error message, which might allow cross-site scripting (XSS) style attacks using web client components that can send arbitrary headers in requests, as demonstrated using a Flash SWF file. 

[+] Vulnerability origin: 
	Oracle HTTP Server (OHS) developed by Oracle Corporation is an OracleAS 10g's Web Server component.  The vulnerable product is based on the Apache 1.3 Web server.  This later is vulnerable to Unfiltered Header Injection  which makes the vulnerability’s origin of this OHS version.

[+] PoC: 
  See the video in Youtube: http://www.youtube.com/watch?v=cBmbkAYXdjo
  See the PDF: http://www.yaboukir.com/wp-content/bugtraq/XSS_Header_Injection_in_OHS_by_Yasser.pdf

[+] Attack:
  	> Atack Prerequisites for a successful exploitation:
		Target software must be a client that allows scripting communication from remote hosts. Crafting the attack to exploit this issue is not a complex process. However most of the unsophisticated attackers will not know that such an attack is possible. Also an attacker needs to reach his victims by enticing them to visit remote site of some sort to redirect them and data to. 
	> Attacker Skills or Knowledge Required
 		- Skill or Knowledge Level: Low
			To achieve a redirection and use of less trusted source, an attacker can simply edit HTTP Headers that are sent to client machine.
       		- Skill or Knowledge Level: High
			Exploiting a client side vulnerability to inject malicious scripts into the browser's executable process.
	> Methods of Attack
		- Injection
		- Modification of Resources
		- Protocol Manipulation
	> Exploit:
		- Steal session IDs, credentials, page content, etc.: 
 As the attacker succeeds in exploiting the vulnerability, he can choose to steal user's credentials in order to reuse or to analyze them later on.
		- Forceful browsing: 
When the attacker targets this Oracle application (through CSRF vulnerabilities, Clickjacking), the user will then be the one who perform the attacks without being aware of it. 
		- Content spoofing:
By manipulating the content, the attacker targets the information that the user would like to get from the Website.

[+]  Solution:
A solution to this issue might be the update/upgrade to the Oracle HTTP Server 11g  which is based on Apache 2.2.  In fact, Oracle supports only the code they ship with the Oracle Application Server 10g. Externally added modules or other changes are not supported.  As a matter of fact, security patches from the Apache organization in its latest versions 1.3.35/2.0.58/2.2.2 to this vulnerability onto Oracle HTTP Server should not be applied. 

[+] References:
  http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-3918
Oracle Application Server 10g Release 3 (10.1.3.1.0) Overview of Oracle HTTP Server, An Oracle White Paper, October 2006
  http://seclists.org/Webappsec/2006/q2/245
  http://www.securiteam.com/securityreviews/5KP0M1FJ5E.html
  http://www.securityfocus.com/archive/1/441014
  http://kb2.adobe.com/cps/403/kb403030.html
  http://www.oracle.com/technetwork/middleware/ias/index-091236.html
  http://www.oracle.com/technetwork/middleware/ias/faq-089946.html
  http://download.oracle.com/otndocs/tech/ias/portal/files/RG/complete_Web_site_ohs_faq.htm#OHS
  http://xss.cx/http-header-injection-expect-response-splitting-cI-113-example-poc.aspx
http://www.cvedetails.com/vulnerability-list/vendor_id-93/product_id-707/opxss-1/Oracle-Application-Server.html

PDF Mirror: https://github.com/offensive-security/exploit-database-bin-sploits/raw/master/sploits/17393.pdf (XSS_Header_Injection_in_OHS_by_Yasser.pdf)