Lucene search

K
drupalDrupal Security TeamDRUPAL-SA-CONTRIB-2011-002
HistoryJan 12, 2011 - 12:00 a.m.

SA-CONTRIB-2011-002 - Panels - Cross Site Scripting (XSS)

2011-01-1200:00:00
Drupal Security Team
www.drupal.org
5

The Panels module allows a site administrator to create customized layouts for multiple uses.

The module does not sanitize some of the user-supplied data before displaying it, leading to a Cross Site Scripting (XSS) vulnerability that may lead to a malicious user gaining full administrative access.

This vulnerability is mitigated by the fact that the attacker must have a role with the ‘administer advanced pane settings’ permission in addition to at least one permission allowing them to create or edit panels, such as ‘use page manager’, ‘administer mini panels’, ‘create panel nodes’ etc.

Versions affected

  • Panels module for Drupal 6.x versions prior to 6.x-3.9

Drupal core is not affected. If you do not use the contributed Panels module, there is nothing you need to do.

Solution

Install the latest version:

  • If you use the Panels module for Drupal 6.x upgrade to Panels 6.x-3.9

See also the Panels project page.

Reported by

Fixed by