Lucene search

K
debiancveDebian Security Bug TrackerDEBIANCVE:CVE-2019-16777
HistoryDec 13, 2019 - 1:15 a.m.

CVE-2019-16777

2019-12-1301:15:00
Debian Security Bug Tracker
security-tracker.debian.org
13

0.002 Low

EPSS

Percentile

56.2%

Versions of the npm CLI prior to 6.13.4 are vulnerable to an Arbitrary File Overwrite. It fails to prevent existing globally-installed binaries to be overwritten by other package installations. For example, if a package was installed globally and created a serve binary, any subsequent installs of packages that also create a serve binary would overwrite the previous serve binary. This behavior is still allowed in local installations and also through install scripts. This vulnerability bypasses a user using the --ignore-scripts install option.