logo
DATABASE RESOURCES PRICING ABOUT US

CVE-2011-3871

Description

Puppet 2.7.x before 2.7.5, 2.6.x before 2.6.11, and 0.25.x, when running in --edit mode, uses a predictable file name, which allows local users to run arbitrary Puppet code or trick a user into editing arbitrary files.


Affected Package


OS OS Version Package Name Package Version
Debian 11 puppet 5.5.22-2
Debian 10 puppet 5.5.10-4
Debian 999 puppet 5.5.22-4

Related