pdfkit.framework -- buffer overflows

2006-02-01T00:00:00
ID DSA-961
Type debian
Reporter Debian
Modified 2006-02-01T00:00:00

Description

"infamous41md" and Chris Evans discovered several heap based buffer overflows in xpdf which are also present in pdfkit.framework, the GNUstep framework for rendering PDF content, and which can lead to a denial of service by crashing the application or possibly to the execution of arbitrary code.

The old stable distribution (woody) does not contain pdfkit.framework packages.

For the stable distribution (sarge) these problems have been fixed in version 0.8-2sarge1.

For the unstable distribution (sid) these problems will be fixed soon.

We recommend that you upgrade your pdfkit.framework package.