imagemagick -- missing shell meta sanitising

2006-01-26T00:00:00
ID DSA-957
Type debian
Reporter Debian
Modified 2006-01-26T00:00:00

Description

Florian Weimer discovered that delegate code in ImageMagick is vulnerable to shell command injection using specially crafted file names. This allows attackers to encode commands inside of graphic commands. With some user interaction, this is exploitable through Gnus and Thunderbird. This update filters out the '$' character as well, which was forgotten in the former update.

For the old stable distribution (woody) this problem has been fixed in version 5.4.4.5-1woody8.

For the stable distribution (sarge) this problem has been fixed in version 6.0.6.2-2.6.

For the unstable distribution (sid) this problem has been fixed in version 6.2.4.5-0.6.

We recommend that you upgrade your imagemagick packages.