smstools -- format string attack

2006-01-09T00:00:00
ID DSA-930
Type debian
Reporter Debian
Modified 2006-01-09T00:00:00

Description

Ulf Härnhammar from the Debian Security Audit project discovered a format string attack in the logging code of smstools, which may be exploited to execute arbitrary code with root privileges.

The original advisory for this issue said that the old stable distribution (woody) was not affected because it did not contain smstools. This was incorrect, and the only change in this updated advisory is the inclusion of corrected packages for woody.

For the old stable distribution (woody) this problem has been fixed in version 1.5.0-2woody0.

For the stable distribution (sarge) this problem has been fixed in version 1.14.8-1sarge0.

For the unstable distribution the package will be updated shortly.

We recommend that you upgrade your smstools package.