ethereal -- buffer overflow

2005-12-13T00:00:00
ID DSA-920
Type debian
Reporter Debian
Modified 2005-12-13T00:00:00

Description

A buffer overflow has been discovered in ethereal, a commonly used network traffic analyser that causes a denial of service and may potentially allow the execution of arbitrary code.

For the old stable distribution (woody) this problem has been fixed in version 0.9.4-1woody14.

For the stable distribution (sarge) this problem has been fixed in version 0.10.10-2sarge3.

For the unstable distribution (sid) this problem will be fixed soon.

We recommend that you upgrade your ethereal packages.