mantis -- several vulnerabilities

2005-11-22T00:00:00
ID DSA-905
Type debian
Reporter Debian
Modified 2005-11-22T00:00:00

Description

Several security related problems have been discovered in Mantis, a web-based bug tracking system. The Common Vulnerabilities and Exposures project identifies the following problems:

A cross-site scripting vulnerability allows attackers to inject arbitrary web script or HTML.

A file inclusion vulnerability allows remote attackers to execute arbitrary PHP code and include arbitrary local files.

An SQL injection vulnerability allows remote attackers to execute arbitrary SQL commands.

Mantis can be tricked into displaying the otherwise hidden real mail address of its users.

The old stable distribution (woody) is not affected by these problems.

For the stable distribution (sarge) these problems have been fixed in version 0.19.2-4.1.

For the unstable distribution (sid) these problems have been fixed in version 0.19.3-0.1.

We recommend that you upgrade your mantis package.