uim -- programming error

2005-11-14T00:00:00
ID DSA-895
Type debian
Reporter Debian
Modified 2005-11-14T00:00:00

Description

Masanari Yamamoto discovered incorrect use of environment variables in uim, a flexible input method collection and library, that could lead to escalated privileges in setuid/setgid applications linked to libuim. Affected in Debian is at least mlterm.

The old stable distribution (woody) does not contain uim packages.

For the stable distribution (sarge) this problem has been fixed in version 0.4.6final1-3sarge1.

For the unstable distribution (sid) this problem has been fixed in version 0.4.7-2.

We recommend that you upgrade your libuim packages.