mailutils -- several vulnerabilities

2005-06-03T00:00:00
ID DSA-732
Type debian
Reporter Debian
Modified 2005-06-03T00:00:00

Description

"infamous41md" discovered several vulnerabilities in the GNU mailutils package which contains utilities for handling mail. These problems can lead to a denial of service or the execution of arbitrary code. The Common Vulnerabilities and Exposures project identifies the following vulnerabilities.

Buffer overflow mail header handling may allow a remote attacker to execute commands with the privileges of the targeted user.

Combined integer and heap overflow in the fetch routine can lead to the execution of arbitrary code.

Denial of service in the fetch routine.

Format string vulnerability can lead to the execution of arbitrary code.

For the stable distribution (woody) these problems have been fixed in version 20020409-1woody2.

For the testing distribution (sarge) these problems have been fixed in version 0.6.1-4.

For the unstable distribution (sid) these problems have been fixed in version 0.6.1-4.

We recommend that you upgrade your mailutils packages.