imagemagick -- buffer overflow

2005-01-19T00:00:00
ID DSA-646
Type debian
Reporter Debian
Modified 2005-01-19T00:00:00

Description

Andrei Nigmatulin discovered a buffer overflow in the PSD image-decoding module of ImageMagick, a commonly used image manipulation library. Remote exploitation with a carefully crafted image could lead to the execution of arbitrary code.

For the stable distribution (woody) this problem has been fixed in version 5.4.4.5-1woody5.

For the unstable distribution (sid) this problem has been fixed in version 6.0.6.2-2.

We recommend that you upgrade your imagemagick packages.