poco -- security update

2018-01-11T00:00:00
ID DSA-4083
Type debian
Reporter Debian
Modified 2018-01-11T00:00:00

Description

Stephan Zeisberg discovered that poco, a collection of open source C++ class libraries, did not correctly validate file paths in ZIP archives. An attacker could leverage this flaw to create or overwrite arbitrary files.

For the oldstable distribution (jessie), this problem has been fixed in version 1.3.6p1-5+deb8u1.

For the stable distribution (stretch), this problem has been fixed in version 1.7.6+dfsg1-5+deb9u1.

We recommend that you upgrade your poco packages.

For the detailed security status of poco please refer to its security tracker page at: <https://security-tracker.debian.org/tracker/poco>