bouncycastle -- security update

2017-04-11T00:00:00
ID DSA-3829
Type debian
Reporter Debian
Modified 2017-04-11T00:00:00

Description

Quan Nguyen discovered that a missing boundary check in the Galois/Counter mode implementation of Bouncy Castle (a Java implementation of cryptographic algorithms) may result in information disclosure.

For the stable distribution (jessie), this problem has been fixed in version 1.49+dfsg-3+deb8u2.

For the upcoming stable distribution (stretch), this problem has been fixed in version 1.54-1.

For the unstable distribution (sid), this problem has been fixed in version 1.54-1.

We recommend that you upgrade your bouncycastle packages.