vim -- security update

2017-02-13T00:00:00
ID DSA-3786
Type debian
Reporter Debian
Modified 2017-02-13T00:00:00

Description

Editor spell files passed to the vim (Vi IMproved) editor may result in an integer overflow in memory allocation and a resulting buffer overflow which potentially could result in the execution of arbitrary code or denial of service.

For the stable distribution (jessie), this problem has been fixed in version 2:7.4.488-7+deb8u2.

For the unstable distribution (sid), this problem has been fixed in version 2:8.0.0197-2.

We recommend that you upgrade your vim packages.