phpgroupware -- several vulnerabilities

2003-08-05T00:00:00
ID DSA-365
Type debian
Reporter Debian
Modified 2003-08-05T00:00:00

Description

Several vulnerabilities have been discovered in phpgroupware:

  • CAN-2003-0504: Multiple cross-site scripting (XSS) vulnerabilities in Phpgroupware 0.9.14.003 (aka webdistro) allow remote attackers to insert arbitrary HTML or web script, as demonstrated with a request to index.php in the addressbook module.
  • CAN-2003-0599: Unknown vulnerability in the Virtual File System (VFS) capability for phpGroupWare 0.9.16preRC and versions before 0.9.14.004 with unknown implications, related to the VFS path being under the web document root.
  • CAN-2003-0657: Multiple SQL injection vulnerabilities in the infolog module of phpgroupware could allow remote attackers to execute arbitrary SQL statements.

For the stable distribution (woody), these problems have been fixed in version 0.9.14-0.RC3.2.woody2.

For the unstable distribution (sid), these problems will be fixed soon. Refer to Debian bug #201980.

We recommend that you update your phpgroupware package.