ruby1.8 -- security update

2015-02-10T00:00:00
ID DSA-3159
Type debian
Reporter Debian
Modified 2015-02-10T00:00:00

Description

It was discovered that the REXML parser, part of the interpreter for the Ruby language, could be coerced into allocating large string objects that could consume all available memory on the system. This could allow remote attackers to cause a denial of service (crash).

For the stable distribution (wheezy), this problem has been fixed in version 1.8.7.358-7.1+deb7u2.

For the upcoming stable distribution (jessie), this problem has been fixed in version 2.1.5-1 of the ruby2.1 source package.

For the unstable distribution (sid), this problem has been fixed in version 2.1.5-1 of the ruby2.1 source package.

We recommend that you upgrade your ruby1.8 packages.