file -- security update

2015-01-08T00:00:00
ID DSA-3121
Type debian
Reporter Debian
Modified 2015-01-08T00:00:00

Description

Multiple security issues have been found in file, a tool/library to determine a file type. Processing a malformed file could result in denial of service. Most of the changes are related to parsing ELF files.

As part of the fixes, several limits on aspects of the detection were added or tightened, sometimes resulting in messages like recursion limit exceeded or too many program header sections.

To mitigate such shortcomings, these limits are controllable by a new - -P, --parameter option in the file program.

For the stable distribution (wheezy), these problems have been fixed in version 5.11-2+deb7u7.

For the upcoming stable distribution (jessie), these problems will be fixed soon.

For the unstable distribution (sid), these problems have been fixed in version 1:5.21+15-1.

We recommend that you upgrade your file packages.