torque -- security update

2014-05-23T00:00:00
ID DSA-2936
Type debian
Reporter Debian
Modified 2014-05-23T00:00:00

Description

John Fitzpatrick from MWR Labs reported a stack-based buffer overflow vulnerability in torque, a PBS-derived batch processing queueing system. An unauthenticated remote attacker could exploit this flaw to execute arbitrary code with root privileges.

For the oldstable distribution (squeeze), this problem has been fixed in version 2.4.8+dfsg-9squeeze4.

For the stable distribution (wheezy), this problem has been fixed in version 2.4.16+dfsg-1+deb7u3.

For the unstable distribution (sid), this problem has been fixed in version 2.4.16+dfsg-1.4.

We recommend that you upgrade your torque packages.