strongswan -- security update

2014-05-05T00:00:00
ID DSA-2922
Type debian
Reporter Debian
Modified 2014-05-05T00:00:00

Description

A vulnerability has been found in the ASN.1 parser of strongSwan, an IKE/IPsec suite used to establish IPsec protected links.

By sending a crafted ID_DER_ASN1_DN ID payload to a vulnerable pluto or charon daemon, a malicious remote user can provoke a null pointer dereference in the daemon parsing the identity, leading to a crash and a denial of service.

For the oldstable distribution (squeeze), this problem has been fixed in version 4.4.1-5.6.

For the stable distribution (wheezy), this problem has been fixed in version 4.5.2-1.5+deb7u4.

For the testing distribution (jessie), this problem has been fixed in version 5.1.2-1.

For the unstable distribution (sid), this problem has been fixed in version 5.1.2-1.

We recommend that you upgrade your strongswan packages.