openssl -- several vulnerabilities

2014-01-01T00:00:00
ID DSA-2833
Type debian
Reporter Debian
Modified 2014-01-01T00:00:00

Description

Multiple security issues have been fixed in OpenSSL: The TLS 1.2 support was susceptible to denial of service and retransmission of DTLS messages was fixed. In addition this update disables the insecure Dual_EC_DRBG algorithm (which was unused anyway, see http://marc.info/?l=openssl-announce&m=138747119822324&w=2 for further information) and no longer uses the RdRand feature available on some Intel CPUs as a sole source of entropy unless explicitly requested.

For the stable distribution (wheezy), these problems have been fixed in version 1.0.1e-2+deb7u1.

For the unstable distribution (sid), these problems have been fixed in version 1.0.1e-5.

We recommend that you upgrade your openssl packages.