chromium-browser -- several vulnerabilities

2013-12-07T00:00:00
ID DSA-2811
Type debian
Reporter Debian
Modified 2013-12-07T00:00:00

Description

Several vulnerabilities have been discovered in the chromium web browser.

Andrey Labunets discovered that the wrong URL was used during validation in the one-click sign on helper.

cloudfuzzer discovered use-after-free issues in the InsertHTML and Indent DOM editing commands.

Bas Venis discovered an address bar spoofing issue.

The chrome 31 development team discovered and fixed multiple issues with potential security impact.

Jakob Kummerow of the Chromium project discovered a buffer overflow in the v8 javascript library.

Jakob Kummerow of the Chromium project discovered an out-of-bounds write in the v8 javascript library.

Jakob Kummerow of the Chromium project discovered an out-of-bounds read in the v8 javascript library.

For the stable distribution (wheezy), these problems have been fixed in version 31.0.1650.63-1~deb7u1.

For the testing distribution (jessie), these problems will be fixed soon.

For the unstable distribution (sid), these problems have been fixed in version 31.0.1650.63-1.

We recommend that you upgrade your chromium-browser packages.