nginx -- information leak

2013-02-17T00:00:00
ID DSA-2627
Type debian
Reporter Debian
Modified 2013-02-17T00:00:00

Description

Juliano Rizzo and Thai Duong discovered a weakness in the TLS/SSL protocol when using compression. This side channel attack, dubbed CRIME, allows eavesdroppers to gather information to recover the original plaintext in the protocol. This update to nginx disables SSL compression.

For the stable distribution (squeeze), this problem has been fixed in version 0.7.67-3+squeeze3.

For the testing distribution (wheezy), and unstable distribution (sid), this problem has been fixed in version 1.1.16-1.

We recommend that you upgrade your nginx packages.