weechat -- several vulnerabilities

2013-01-05T00:00:00
ID DSA-2598
Type debian
Reporter Debian
Modified 2013-01-05T00:00:00

Description

Two security issues have been discovered in WeeChat, a fast, light and extensible chat client:

X.509 certificates were incorrectly validated.

The hook_process function in the plugin API allowed the execution of arbitrary shell commands.

For the stable distribution (squeeze), these problems have been fixed in version 0.3.2-1+squeeze1.

For the testing distribution (wheezy), these problems have been fixed in version 0.3.8-1+deb7u1.

For the unstable distribution (sid), these problems have been fixed in version 0.3.9.2-1.

We recommend that you upgrade your weechat packages.