request-tracker3.8 -- several vulnerabilities

ID DSA-2480
Type debian
Reporter Debian
Modified 2012-09-15T00:00:00


Several vulnerabilities were discovered in Request Tracker, an issue tracking system:

The vulnerable-passwords scripts introduced for CVE-2011-0009 failed to correct the password hashes of disabled users.

Several cross-site scripting issues have been discovered.

Password hashes could be disclosed by privileged users.

Several cross-site request forgery vulnerabilities have been found. If this update breaks your setup, you can restore the old behaviour by setting $RestrictReferrer to 0.

The code to support variable envelope return paths allowed the execution of arbitrary code.

Disabled groups were not fully accounted as disabled.

SQL injection vulnerability, only exploitable by privileged users.

Please note that if you run request-tracker3.8 under the Apache web server, you must stop and start Apache manually. The restart mechanism is not recommended, especially when using mod_perl.

For the stable distribution (squeeze), these problems have been fixed in version 3.8.8-7+squeeze5.

For the unstable distribution (sid), these problems have been fixed in version 4.0.5-3.

We recommend that you upgrade your request-tracker3.8 packages.