asterisk -- several vulnerabilities

2012-04-25T00:00:00
ID DSA-2460
Type debian
Reporter Debian
Modified 2012-04-25T00:00:00

Description

Several vulnerabilities were discovered in the Asterisk PBX and telephony toolkit:

Russell Bryant discovered a buffer overflow in the Milliwatt application.

David Woolley discovered a privilege escalation in the Asterisk manager interface.

Russell Bryant discovered a buffer overflow in the Skinny driver.

For the stable distribution (squeeze), this problem has been fixed in version 1:1.6.2.9-2+squeeze5.

For the unstable distribution (sid), this problem will be fixed soon.

We recommend that you upgrade your asterisk packages.