plib -- buffer overflow

2012-03-04T00:00:00
ID DSA-2425
Type debian
Reporter Debian
Modified 2012-03-04T00:00:00

Description

It was discovered that PLIB, a library used by TORCS, contains a buffer overflow in error message processing, which could allow remote attackers to execute arbitrary code.

For the stable distribution (squeeze), this problem has been fixed in version 1.8.5-5+squeeze1.

For the testing distribution (wheezy) and the unstable distribution (sid), this problem has been fixed in version 1.8.5-5.1.

We recommend that you upgrade your plib packages.