iceape -- several vulnerabilities

2012-02-02T00:00:00
ID DSA-2402
Type debian
Reporter Debian
Modified 2012-02-02T00:00:00

Description

Several vulnerabilities have been found in the Iceape internet suite, an unbranded version of Seamonkey:

Gregory Fleischer discovered that IPv6 URLs were incorrectly parsed, resulting in potential information disclosure.

Jesse Ruderman and Bob Clary discovered memory corruption bugs, which may lead to the execution of arbitrary code.

regenrecht discovered that missing input sanitising in the Ogg Vorbis parser may lead to the execution of arbitrary code.

Nicolas Gregoire and Aki Helin discovered that missing input sanitising in XSLT processing may lead to the execution of arbitrary code.

For the stable distribution (squeeze), this problem has been fixed in version 2.0.11-10.

For the unstable distribution (sid), this problem has been fixed in version 2.0.14-10.

We recommend that you upgrade your iceape packages.