openssl -- out-of-bounds read

2012-01-23T00:00:00
ID DSA-2392
Type debian
Reporter Debian
Modified 2012-01-23T00:00:00

Description

Antonio Martin discovered a denial-of-service vulnerability in OpenSSL, an implementation of TLS and related protocols. A malicious client can cause the DTLS server implementation to crash. Regular, TCP-based TLS is not affected by this issue.

For the oldstable distribution (lenny), this problem has been fixed in version 0.9.8g-15+lenny16.

For the stable distribution (squeeze), this problem has been fixed in version 0.9.8o-4squeeze7.

For the testing distribution (wheezy) and the unstable distribution (sid), this problem has been fixed in version 1.0.0g-1.

We recommend that you upgrade your openssl packages.