proftpd-dfsg -- several vulnerabilities

2011-11-16T00:00:00
ID DSA-2346
Type debian
Reporter Debian
Modified 2011-11-16T00:00:00

Description

Several vulnerabilities were discovered in ProFTPD, an FTP server:

  • (No CVE id)

ProFTPD incorrectly uses data from an unencrypted input buffer after encryption has been enabled with STARTTLS, an issue similar to CVE-2011-0411.

ProFTPD uses a response pool after freeing it under exceptional conditions, possibly leading to remote code execution. (The version in lenny is not affected by this problem.)

For the oldstable distribution (lenny), this problem has been fixed in version 1.3.1-17lenny9.

For the stable distribution (squeeze), this problem has been fixed in version 1.3.3a-6squeeze4.

For the testing distribution (wheezy) and the unstable distribution (sid), this problem has been fixed in version 1.3.4~rc3-2.

We recommend that you upgrade your proftpd-dfsg packages.