libxfont -- buffer overflow

2011-08-12T00:00:00
ID DSA-2293
Type debian
Reporter Debian
Modified 2011-08-12T00:00:00

Description

Tomas Hoger found a buffer overflow in the X.Org libXfont library, which may allow for a local privilege escalation through crafted font files.

For the oldstable distribution (lenny), this problem has been fixed in version 1.3.3-2.

For the stable distribution (squeeze), this problem has been fixed in version 1.4.1-3.

For the unstable distribution (sid), this problem has been fixed in version 1.4.4-1.

We recommend that you upgrade your libxfont packages.