libxml2 -- buffer overflow

2011-06-06T00:00:00
ID DSA-2255
Type debian
Reporter Debian
Modified 2011-06-06T00:00:00

Description

Chris Evans discovered that libxml was vulnerable to buffer overflows, which allowed a crafted XML input file to potentially execute arbitrary code.

For the oldstable distribution (lenny), this problem has been fixed in version 2.6.32.dfsg-5+lenny4.

For the stable distribution (squeeze), this problem has been fixed in version 2.7.8.dfsg-2+squeeze1.

For the unstable distribution (sid), this problem has been fixed in version 2.7.8.dfsg-3.

We recommend that you upgrade your libxml2 packages.