pam-pgsql -- buffer overflow

2011-02-26T00:00:00
ID DSA-2173
Type debian
Reporter Debian
Modified 2011-02-26T00:00:00

Description

It was discovered that pam-pgsql, a PAM module to authenticate using a PostgreSQL database, was vulnerable to a buffer overflow in supplied IP-addresses.

For the oldstable distribution (lenny), this problem has been fixed in version 0.6.3-2+lenny1.

For the stable distribution (squeeze), this problem has been fixed in version 0.7.1-4+squeeze1.

For the testing (wheezy) and unstable (sid) distributions, this problem has been fixed in version 0.7.1-5.

We recommend that you upgrade your pam-pgsql packages.