mailman -- several vulnerabilities

2011-02-18T00:00:00
ID DSA-2170
Type debian
Reporter Debian
Modified 2011-02-18T00:00:00

Description

Two cross site scripting vulnerabilities were been discovered in Mailman, a web-based mailing list manager. These allowed an attacker to retrieve session cookies via inserting crafted JavaScript into confirmation messages (CVE-2011-0707) and in the list admin interface (CVE-2010-3089; oldstable only).

For the oldstable distribution (lenny), these problems have been fixed in version 1:2.1.11-11+lenny2.

For the stable distribution (squeeze), this problem has been fixed in version 1:2.1.13-5.

For the testing (wheezy) and unstable distribution (sid), this problem has been fixed in version 1:2.1.14-1.

We recommend that you upgrade your mailman packages.