vlc -- missing input sanitising

2011-02-10T00:00:00
ID DSA-2159
Type debian
Reporter Debian
Modified 2011-02-10T00:00:00

Description

Dan Rosenberg discovered that insufficient input validation in VLC's processing of Matroska/WebM containers could lead to the execution of arbitrary code.

For the stable distribution (squeeze), this problem has been fixed in version 1.1.3-1squeeze3.

The version of vlc in the oldstable distribution (lenny) is affected by further issues and will be addressed in a followup DSA.

For the unstable distribution (sid), this problem has been fixed in version 1.1.7-1.

We recommend that you upgrade your vlc packages.