samba -- buffer overflow

2010-09-16T00:00:00
ID DSA-2109
Type debian
Reporter Debian
Modified 2010-09-16T00:00:00

Description

A vulnerability has been discovered in samba, a SMB/CIFS file, print, and login server for Unix.

The sid_parse() function does not correctly check its input lengths when reading a binary representation of a Windows SID (Security ID). This allows a malicious client to send a sid that can overflow the stack variable that is being used to store the SID in the Samba smbd server. (CVE-2010-3069)

For the stable distribution (lenny), this problem has been fixed in version 3.2.5-4lenny13.

For the testing distribution (squeeze) and the unstable distribution (sid), this problem will be fixed in version 3.5.5~dfsg-1.

We recommend that you upgrade your samba packages. The packages for the mips architecture are not included in this upgrade. They will be released as soon as they become available.