cvsnt -- programming error

2010-09-14T00:00:00
ID DSA-2108
Type debian
Reporter Debian
Modified 2010-09-14T00:00:00

Description

It has been discovered that in cvsnt, a multi-platform version of the original source code versioning system CVS, an error in the authentication code allows a malicious, unprivileged user, through the use of a specially crafted branch name, to gain write access to any module or directory, including CVSROOT itself. The attacker can then execute arbitrary code as root by modifying or adding administrative scripts in that directory.

For the stable distribution (lenny), this problem has been fixed in version 2.5.03.2382-3.3+lenny1.

We recommend that you upgrade your cvsnt package.