socat -- incorrect user-input validation

2010-08-06T00:00:00
ID DSA-2090
Type debian
Reporter Debian
Modified 2010-08-06T00:00:00

Description

A stack overflow vulnerability was found in socat that allows an attacker to execute arbitrary code with the privileges of the socat process.

This vulnerability can only be exploited when an attacker is able to inject more than 512 bytes of data into socat's argument.

A vulnerable scenario would be a CGI script that reads data from clients and uses (parts of) this data as argument for a socat invocation.

For the stable distribution (lenny), this problem has been fixed in version 1.6.0.1-1+lenny1.

For the unstable distribution (sid), this problem has been fixed in version 1.7.1.3-1.

We recommend that you upgrade your socat package.