cups -- format string vulnerability

2010-03-03T00:00:00
ID DSA-2007
Type debian
Reporter Debian
Modified 2010-03-03T00:00:00

Description

Ronald Volgers discovered that the lppasswd component of the cups suite, the Common UNIX Printing System, is vulnerable to format string attacks due to insecure use of the LOCALEDIR environment variable. An attacker can abuse this behaviour to execute arbitrary code via crafted localization files and triggering calls to _cupsLangprintf(). This works as the lppasswd binary happens to be installed with setuid 0 permissions.

For the stable distribution (lenny), this problem has been fixed in version 1.3.8-1+lenny8.

For the testing distribution (squeeze) this problem will be fixed soon.

For the unstable distribution (sid) this problem has been fixed in version 1.4.2-9.1.

We recommend that you upgrade your cups packages.