nspr -- several vulnerabilities

2009-11-08T00:00:00
ID DSA-1931
Type debian
Reporter Debian
Modified 2009-11-08T00:00:00

Description

Several vulnerabilities have been discovered in the NetScape Portable Runtime Library, which may lead to the execution of arbitrary code. The Common Vulnerabilities and Exposures project identifies the following problems:

A programming error in the string handling code may lead to the execution of arbitrary code.

An integer overflow in the Base64 decoding functions may lead to the execution of arbitrary code.

The old stable distribution (etch) doesn't contain nspr.

For the stable distribution (lenny), these problems have been fixed in version 4.7.1-5.

For the unstable distribution (sid) these problems have been fixed in version 4.8.2-1.

We recommend that you upgrade your NSPR packages.