postgresql-ocaml -- missing escape function

2009-10-14T00:00:00
ID DSA-1909
Type debian
Reporter Debian
Modified 2009-10-14T00:00:00

Description

It was discovered that postgresql-ocaml, OCaml bindings to PostgreSQL's libpq, was missing a function to call PQescapeStringConn(). This is needed, because PQescapeStringConn() honours the charset of the connection and prevents insufficient escaping, when certain multibyte character encodings are used. The added function is called escape_string_conn() and takes the established database connection as a first argument. The old escape_string() was kept for backwards compatibility.

Developers using these bindings are encouraged to adjust their code to use the new function.

For the oldstable distribution (etch), this problem has been fixed in version 1.5.4-2+etch1.

For the stable distribution (lenny), this problem has been fixed in version 1.7.0-3+lenny1.

For the testing distribution (squeeze) and the unstable distribution (sid), this problem has been fixed in version 1.12.1-1.

We recommend that you upgrade your postgresql-ocaml packages.